求助:VRAY3.6SUAPP汉化补丁与坯子库不兼容

首页 论坛 【插件】技术讨论 求助:VRAY3.6SUAPP汉化补丁与坯子库不兼容

该主题包含 5 个回复,有 3 个参与人,并且由  su9962 月, 1 周 前 最后一次更新。

正在查看 6 个帖子 - 1 至 6 (共计 6 条)
  • 作者
    帖子
  • #33617

    markzy
    参与者
    等级:泥水混合物
    泥巴: 1.3

    遇到VR3.6与坯子库插件不兼容的情况,请问有什么方法能够解决……两个都需要两个都有用,总不能真的去装两个SU这种笨办法来解决……

    #33618

    markzy
    参与者
    等级:泥水混合物
    泥巴: 1.3

    系统为windows10,软件版本su2018

    #33809

    jeff1981
    参与者
    等级:白银泥坯
    泥巴: 34.6

    用记事本打开C:\Program Files\Chaos Group\V-Ray\V-Ray for SketchUp\extension\ruby\init.rb文件删掉VRay.require_crypt(__FILE__, “gui/gui_zh_cn”)这一句保存就可以了,主要是SUbar的汉化菜单和很多插件冲突。
    此方法转自全屋定制联盟

    附件:
    你必须登录以后查看附件
    #33912

    markzy
    参与者
    等级:泥水混合物
    泥巴: 1.3

    楼上可以解决问题,但是是通过把补丁去掉的方式啊……求保留汉化的方式

    #33927

    jeff1981
    参与者
    等级:白银泥坯
    泥巴: 34.6

    菜单的使用率很小,目前没有全部保留的方法,除非你能自己重写ruby菜单。

    #39319

    su996
    参与者
    等级:小泥点
    泥巴: 0.5

    你好,使用了你的方法,还是没有效果呢?
    载入文件 C:/Program Files/Chaos Group/V-Ray/V-Ray for SketchUp/extension/ruby/init.rb 时出错
    Error: #<NoMethodError: undefined method `init’ for VRay:Module>
    C:/Program Files/Chaos Group/V-Ray/V-Ray for SketchUp/extension/ruby/init.rb:7:in `<top (required)>’
    E:/su/Tools/extensions.rb:197:in `require’
    E:/su/Tools/extensions.rb:197:in `load’
    C:/ProgramData/SketchUp/SketchUp 2018/SketchUp/Plugins/vfs.rb:26:in `register_extension’
    C:/ProgramData/SketchUp/SketchUp 2018/SketchUp/Plugins/vfs.rb:26:in `<module:VRay>’
    C:/ProgramData/SketchUp/SketchUp 2018/SketchUp/Plugins/vfs.rb:4:in `<top (required)>’

    谢谢

正在查看 6 个帖子 - 1 至 6 (共计 6 条)

抱歉,回复评论必需登录。

返回顶部
返回刚才
微信
QQ
前往评论